Invalid Toolchain. Your app was built with an unsupported version of Xcode or SDK

制作メモ:Xcode

ごく普通に、App StoreからダウンロードしたX code11.2で。
いつものようにアプリアップデート申請に向けて、Archive→Validateをしたら、タイトルのような文章が出て、どうにもならなくなりました。

エラー内容

”Invalid Toolchain. Your app was built with an unsupported version of Xcode or SDK.
If you plan to submit this build to the App Store, make sure you are using the GM version of Xcode 10.1 and the SDK for iOS 12.1 and watchOS 5.1, Xcode 7.1 and the SDK for tvOS 9, or Xcode 6 and the SDK for macOS 10.9 or later.
If you are using an Xcode beta version to test your app, make sure you are using the latest supported version.
For more information about supported beta versions, view the App Store Connect What's New page (https://developer.apple.com/app-store-connect/whats-new/).”

英語はさっぱり分からない派ですが、たぶん
「App Store向けにビルドしたいなら、ちゃんとサポートされた最新のXcodeでビルドしてよね」
ってことではないかと思いました。

いやいや、ちゃんとApp Storeからダウンロードした最新のXcodeで、ごく普通にやってるだけなのですが。
困りました。

解決法

Mac OSもXcodeも最新だし、知識の少ない私はお手上げ。
でも問題はXcode自体だと思ったので、Apple Developerサイトから「X code 11.2.1」のナントカ板(名前忘れた)をダウンロード&インストール。
そちらで改めてArchive→Validateをしたら、なんの問題もなく成功。
そのままアップロードまで通常通りに出来ました。

App Storeで公開されているX codeなのに、こんなことになる場合があるのですね。
X codeがアップデートされて、ダウンロードする度に「空き領域不足」など言われて大変な思いをしているのに、勘弁してくれ〜いという感じです。
でもこれでまた一つ、学べました。多分ね。

Junko HonmaのApplications
初級
詳しいページ
App Store
中級
詳しいページ
App Store
上級
詳しいページ
App Store
和声聴音 初級
詳しいページ
App Store
コード聴音
詳しいページ
APP Store
コード聴音 上級
詳しいページ
App Store
聴音でセッション
詳しいページ
App Store